В Agisoft Viewer доступны инструменты измерения и рисования. Вы можете измерять расстояния на модели, а также площадь и объем реконструированной 3D-модели. Все инструменты доступны на основной панели инструментов или в меню Инструменты

 

Инструменты измерения

Измерения в Agisoft Viewer производятся в метрах. В Agisoft Viewer доступны следующие инструменты измерения

  • Линейка
  • Измерение профиля
  • Измерение объема

Чтобы измерить расстояние на модели, выберите инструмент Линейка на панели инструментов и выберите расстояние, которое вы хотите измерить, щелкнув левой кнопкой мыши по точкам начала и конца отрезка. Измеренное расстояние появится в прямоугольнике рядом с конечной точкой.

Чтобы построить профиль, выберите инструмент Измерение профиля на панели инструментов и нарисуйте полилинию, чтобы задать направляющую профиля. Нажмите левой кнопкой мыши, чтобы начать рисование, и правой кнопкой мыши (или нажмите Esc), чтобы завершить ломаную линию. Профиль появится во всплывающем окне Измерение профиля, как показано на анимации ниже.


Профиль можно сохранить, нажав кнопку Сохранить (как выделено на изображении ниже). Диапазон поддерживаемых форматов включает векторные форматы: KML, SHP, DXF; и растровые форматы: JPEG, JPEG 2000, PNG, TIFF, BMP, OpenEXR, TARGA. 


Для измерения объема сначала необходимо построить ограничивающую область. Выберите инструмент Измерение объема на панели инструментов и нарисуйте полигон вокруг целевой области измерения. Начните рисование, нажав левой кнопкой мыши, чтобы создать первую точку многоугольника, затем нарисуйте ограничивающую область, как показано на изображении ниже. Чтобы завершить многоугольник, нажмите правой кнопкой мыши (или кнопку Esc). Результат измерения отобразится в окне Измерение объема.


В окне инструмента Измерение объема в разделе Граница доступна следующая информация:

 

- Долгота, широта и высота вершин ограничивающей области.

- Периметр, 2D (значение высоты не используется для расчета)

- Периметр, 3D

- Площадь, 2D

- Система координат, используемая в проекте

 

В разделе Объем можно выбрать предпочтительную базовую плоскость для расчета объема. Представленные варианты: Аппроксимирующая плоскость, Средний уровень, Заданный уровень. Аппроксимирующая поверхность и Средний уровень рассчитываются на основе высот вершин ограничивающего многоугольника. Объем, измеренный относительно Заданного уровня, позволяет отслеживать изменения объема для одной и той же площади с течением времени. Уровень задается пользователем в соответствующем поле. Нажмите кнопку Обновить, чтобы объем пересчитывался относительно заданного уровня.

Объем рассчитывается выше и ниже плоскости, а также вычисляется Общий объем по следующей формуле: Общий объем = Объем над плоскостью - Объем под плоскостью


Инструменты рисования

Инструменты рисования доступны только для векторного слоя, поэтому для начала вам нужно либо добавить новый векторный слой, либо импортировать слой-фигуру в проект. Чтобы создать векторный слой, используйте кнопку Новый векторный слой на панели Слои или соответствующую опцию в меню Файл. 


В Agisoft Viewer доступны следующие инструменты рисования:

  • Нарисовать точку
  • Нарисовать ломаную
  • Нарисовать полигон

Свойства фигуры указываются на вкладке Свойства, доступной в меню Вид > Панели > Свойства. На данной панели отображаются свойства выбранной фигуры. Чтобы выбрать фигуру, щелкните соответствующий полигон/ломаную/точку в окне проекта. Вы можете указать название, описание и слой для выбранной фигуры в диалоговом окне Свойства.


Чтобы создать дополнительный атрибут для фигуры, нажмите кнопку Добавить атрибут на панели Свойства. Чтобы отредактировать атрибут, дважды щелкните соответствующее поле левой кнопкой мыши.


Чтобы задать свойства слоя, выберите команду Свойства в контекстном меню слоя. В свойствах слоя можно включить/отключить параметр Показывать подписи к фигурам, Цвет, Прозрачность, а также поменять название слоя.