Обычно весь процесс фотограмметрической обработки полностью выполняется в Agisoft Metashape, но в некоторых случаях может потребоваться выполнить окончательное выравнивание проекта в каком-то конкретном программном обеспечении. В этом руководстве показано, как в Agisoft Metashape можно использовать результаты уравнивания, полученных с помощью сервиса BINGO.


Создать проект Agisoft Metashape 

Запустите Agisoft Metashape. Выберите команду Обработка > Добавить снимки.

Metashape автоматически загрузит GPS-координаты из записанных во время полета метаданных EXIF (если это предполагает модель БПЛА).

Если координаты центров снимков недоступны в метаданных, их можно импортировать отдельно с помощью команды Файл > Импорт > Импортировать привязку.

После загрузки координат в окне Модель отобразятся позиции снимков:

Выровнять снимки

Выберите команду Обработка > Выровнять снимки. Выберите оптимальные параметры в диалоговом окне. В большинстве случаев подойдут параметры Высокая точность, Общая преселекция и По привязке (по Исходным данным). Нажмите OK, чтобы начать выравнивание снимков.

После завершения выравнивания рассчитанные положения снимков и связующие точки отобразятся в окне Модель:

Добавить контрольные точки

Если подготовлены наземные контрольные/опорные точки для данного проекта, их необходимо загрузить в Metashape перед экспортом данных в BINGO. Рекомендуемый способ работы с контрольными точками в Metashape - загрузить координаты точек с помощью команды Импортировать привязку и расставить маркеры на всех снимках, куда попали координаты добавленных точек. Данный этап обработки подробно описан в руководстве Обработка аэрофотоснимков (с опорными точками и без), создание ЦММ и ортофотоплана в соответствующем разделе.


Построить разреженное облако точек

Для эффективной обработки BINGO требуется небольшое количество высококачественных связующих точек - намного меньше, чем обычное количество связующих точек в Metashape.

Чтобы уменьшить количество связующих точек, создаваемых в Metashape, выберите команду Инструменты > Связующие точки > Проредить связующие точкиВ диалоговом окне инструмента выберите подходящее количество связующих точек, которые будут сохранены. Рекомендуется установить лимит 1000 проекций на снимок для экспорта в BINGO. По завершении нажмите кнопку ОК.

1000 точек на снимок немного больше, чем требуется BINGO, но это избыточное количество позволит выполнить дополнительное прореживание в BINGO для достижения наилучших результатов.


Экспорт проекта в BINGO

После завершения первоначального выравнивания в Metashape можно экспортировать проект BINGO со связующими точками, маркерами и исходными параметрами ориентации камеры.

Выберите команду Файл > Экспорт > Экспорт камер. Выберите формат BINGO Project (*.dat) из списка и укажите папку, в которую необходимо сохранить проект BINGO.

В диалоговом окне Экспорт камер выберите ориентацию оси изображения так, чтобы ось X указывала в направлении полета. Снимите галочку "Сохранять ошибочные связующие точки", чтобы убедиться, что экспортированные связующие точки не содержат "выбросов". Настройте другие параметры в соответствии с вашими требованиями и нажмите кнопку ОК, чтобы начать экспорт.

Открыть проект BINGO в BINGO Manager

Запустите BINGO Manager. Выберите команду File > Select Project и перейдите в папку с проектом BINGO, экспортированным из Metashape.


Проредить связующие точки в BINGO 

Выберите команду Samba из меню Tools > Auxiliary menu, чтобы запустить модуль для дополнительного прореживания связующих точек.

Установите галочки на опции "Save any existing output file to old" и "Remove obsolete points from file".

Нажмите кнопку Format, чтобы загрузить конфигурацию камеры из проекта. После загрузки конфигурации камеры нажмите кнопку Run, чтобы выполнить операцию прореживания. По завершении закройте программу SAMBA.


Выполнить уравнивание в BINGO 

Выберите команду Bingo в меню Run, чтобы начать уравнивание. По завершении выберите команду Skip в меню Run, чтобы пропустить создание файла.

Изучите в файле bingo.lis результаты корректировки. Если результаты корректировки неудовлетворительны, продолжайте выполнять команды Bingo и Skip, проверяя файл bingo.lis после каждой итерации.

По завершении закройте BINGO Manager.


Импортировать результаты корректировки в Metashape

Откройте исходный проект Metashape. Выберите команду Файл > Импорт > Импортировать камер. Выберите формат файла BINGO (*.dat) и перейдите к файлу itera.dat в папке проекта BINGO.

В диалоговом окне Импорт камер выберите ту же ориентацию снимка, которая была использована для экспорта, и нажмите кнопку ОК, чтобы импортировать результаты уравнивания BINGO.

В диалоговом окне Загрузить сетки дисторсий выберите сетки искажений, созданные в BINGO, если они есть. Если сетки искажения не создавались, нажмите Отмена.


Выполнить остальные этапы обработки

После импорта результатов уравнивания BINGO можно перейти к другим необходимым вам этапам обработки: построение плотного облака точек, цифровой модели местности/рельефа (ЦММ/ЦМР), ортофотоплана, полигональной/тайловой модели. Подробнее про данные этапы см. руководство Обработка аэрофотоснимков (с опорными точками и без), создание ЦММ и ортофотоплана.