В приведенном ниже руководстве описаны основные этапы обработки и рекомендуемые параметры для обработки аэрофотоснимков в Agisoft Metashape Professional без использования наземных опорных точек. Данные для проекта получены с помощью SenseFly eBee. Руководство также включает описание процедуры проверки точности с помощью контрольных точек.

*Вы также можете посмотреть веб-семинар с командой SenseFly - Exploring eMotion 3.5.0 & Processing with Agisoft Photoscan.


Можно сохранить проект в SenseFly как проект Agisoft Metashape, выбрав соответствующий пункт в диалоговом окне программы (формат файла .psx). После сохранения проекта его можно открыть в Metashape. 


Создание проекта

1. Выберите команду Файл > Открыть

2. Выберите файл проекта в диалоговом окне Открыть файл. В окне просмотра Модель во время съемки будут отображаться положения камер. 

Если проекта нет, используйте меню Обработка > Добавить снимки, чтобы выбрать изображения, которые необходимо обработать.


Выравнивание снимков

Этап обработки выравнивания снимков включает в себя поиск характерных и общих точек и совмещение снимков по ним, фототриангуляцию и процедуру корректировки ошибок. 


1. Выберите меню Обработка > Выровнять снимки.

2. Установите необходимые настройки в диалоговом окне Выровнять снимки:

Результаты этого этапа обработки включают внешние (положение камеры + ориентация) и внутренние параметры, а также разреженное облако точек в качестве визуализации и оценки качества выравнивания снимков. Результаты первого шага обработки, отображаемые в окне Модель

Metashape оценивает параметры внутренней и внешней ориентации камеры во время совмещения снимков. Эта оценка выполняется только с использованием данных из снимков, и в окончательных оценках могут быть некоторые ошибки. Точность окончательной оценки зависит от многих факторов, таких как перекрытие соседних снимков, а также от конфигурации поверхности объекта. Эти ошибки могут привести к нелинейным деформациям итоговой модели. 

Чтобы увидеть ошибки, после завершения процедуры выравнивания нажмите кнопку Просмотр ошибок, и ошибки появятся на  панели Привязка


Указание точности 

Информацию о точности можно экспортировать из метаданных XMP. Поставьте галочку "Загружать точность КЦФ из XMP-метаданных" на вкладке Дополнительно в меню Инструменты > Настройки.

Информацию о точности исходных координат, а также углах ориентации можно также загрузить из файла CSV. Отметьте опцию Точность и укажите номера столбцов, из которых должна считываться точность данных. Можно указать один и тот же столбец точности для всех трех координат/углов. 

Дополнительно можно указать данные о точности координат/углов ориентации. Выберите команду Изменить в контекстном меню снимка на панели Привязка и введите данные точности для координат/углов. 


Оптимизация

Применение оптимизации полезно в большинстве случаев, особенно если необходимо получить более точные результаты. Возможные нелинейные деформации модели могут быть устранены путем оптимизации рассчитанного облака точек и параметров камеры на основе известных координат наземных опорных точек. Во время этой оптимизации Metashape корректирует рассчитанные координаты точек и параметры камеры, сводя к минимуму сумму ошибки репроецирования и ошибки несовпадения координат опорных точек. 


1. Нажмите кнопку Оптимизировать на панели инструментов на панели Привязка:

2. В диалоговом окне Оптимизировать положения камер отметьте галочками параметры, которые необходимо оптимизировать. 

В некоторых случаях, когда загружены точные местоположения камер и не используются опорные точки, может быть полезным включить параметр Рассчитывать дополнительные поправки в диалоговом окне Оптимизировать положения камер, чтобы повысить точность результатов обработки.


3. Нажмите кнопку ОК, чтобы начать оптимизацию. 

В Metashape применяются 2 типа маркеров - контрольные и опорные. Опорные маркеры используются для привязки модели. В то время как контрольные маркеры используются для проверки точности результатов выравнивания снимков и оптимизации выравнивания. Более подробную информацию о контрольных и опорных точках вы можете найти в соответствующем разделе статьи Обработка аэрофотоснимков (с опорными точками и без), создание ЦММ и ортофотоплана.


Построение плотного облака

1. Выберите команду Построить плотное облако в меню Обработка.

2. В диалоговом окне Построить плотное облако выберите оптимальные параметры реконструкции и нажмите кнопку OK

  • Для получения более детальной и точной геометрии можно использовать более высокие качество, но тогда потребуется больше времени для обработки.
  • Рекомендуется Мягкая фильтрация карт глубины.


3. Появится окно процесса выполнения, отображающее текущее состояние обработки. Чтобы отменить обработку, нажмите кнопку Отмена.


Построение цифровой модели местности (ЦММ)

ЦММ представляет модель поверхности в виде регулярной сетки из значений высоты. Матрица высот может быть сгенерирована из плотного и разреженного облака точек, карт глубины или полигональной модели. ЦММ строится на основе информации, ограниченной областью построения.


1. Выберите команду Построить ЦММ в меню Обработка.

2. В диалоговом окне Построить ЦММ задайте оптимальные настройки. Нажмите кнопку ОК.

3. Появится окно процесса выполнения, отображающее текущее состояние обработки. Чтобы отменить обработку, нажмите кнопку Отмена.

В одном блоке может храниться более одного экземпляра ЦММ. Если вы хотите сохранить текущий экземпляр ЦММ и построить новую модель в активном блоке, нажмите правой кнопкой мыши на ЦММ в раскрытом блоке и снимите галочку Использовать по умолчанию. Этот шаг необходимо выполнить перед построением новой ЦММ.


Построение ЦМР 

Для создания ЦМР необходимо сначала классифицировать точки облака. Для запуска процедуры выберите функцию Инструменты > Плотное облако > Классифицировать точки рельефа. Этот инструмент позволяет автоматически извлечь точки земли из всех точек плотного облака.

Параметры зависят от сложности сцены - необходимо выставить их в зависимости от типа местности и площади готового плотного облака. Поэтому, если первый результат классификации не соответствует вашим требованиям, нужно сбросить классификацию, откорректировать параметры и отследить изменения результатов. Более подробную информацию о классификации в Metashape  можно найти в инструкции Классификация плотного облака точек или в соответствующем разделе Руководства пользователя Agisoft Metashape Pro

1. Выберите команду Построить ЦММ в меню Обработка.

2. В диалоговом окне Построить ЦММ задайте оптимальные параметры. Для построения ЦМР выбрать необходимые классы точек (Земля). Нажмите кнопку ОК.

3. Появится окно процесса выполнения, отображающее текущее состояние обработки. Чтобы отменить обработку, нажмите кнопку Отмена.

В Metashape можно выполнять измерения на основе ЦММ/ЦМР. Применение функций измерения подробно описано в инструкции Измерения на основе ЦММ, профили и изолинии.


Построение ортофотоплана

1. Выберите команду Построить ортофотоплан в меню Обработка.

2. В диалоговом окне выберите оптимальные параметры. Нажмите кнопку ОК.

3. Появится окно процесса выполнения, отображающее текущее состояние обработки. Чтобы отменить обработку, нажмите кнопку Отмена.


Экспорт результатов

  • Экспорт разреженного и плотного облаков точек

1. Выберите команду Экспорт точек в меню Файл

2. Выберите папку сохранения, формат файла и введите его название. Нажмите кнопку Сохранить.

3. В диалоговом окне Экспорт облака точек выберите нужное облако точек - разреженное или плотное. Укажите систему координат и оптимальные параметры экспорта, применимые к выбранному типу файла, включая классы плотного облака, которые необходимо сохранить. 

4. Нажмите кнопку ОК. Появится окно процесса выполнения, отображающее текущее состояние обработки. Чтобы отменить обработку, нажмите кнопку Отмена.


Metashape поддерживает экспорт облака точек в следующие форматы: Wavefront OBJ (*.obj); Stanford PLY (*.ply); XYZ Point Cloud (*.txt); ASPRS LAS (*.las); LAZ (*.laz); ASTM E57 (*.e57); Topcon CL3 (*.cl3); ASCII PTS (*.pts); Autodesk DXF (*.dxf); U3D (*.u3d); Adobe PDF (*.pdf); Point Cloud Data (*.pcd); potree (*.zip); Cesium 3D Tiles (*.zip); Agisoft OC3 (*.oc3). 


Сохранение информации о цветах облака точек не поддерживается форматами OBJ и DXF. Информация о нормалях точек облака не поддерживается форматами LAS, LAZ, PTS, CL3 и DXF.


  • Экспорт ортофотоплана

1. Выберите  команду Экспорт ортофотоплана в меню Файл.

2. В диалоговом окне Экспорт ортофотоплана укажите систему координат для сохранения ортофотоплана. Установите флажок Создать файл KML и/или Создать файл World, чтобы сохранить файлы, необходимые для географической привязки ортофотоплана в Google Earth и/или ГИС-программах.

3. Нажмите кнопку Экспорт.

4. Выберите папку сохранения, формат файла и введите его название. Нажмите кнопку Сохранить.

5. Появится окно процесса выполнения, отображающее текущее состояние обработки. Чтобы отменить обработку, нажмите кнопку Отмена.


Metashape поддерживает экспорт ортофотоплана в следующие форматы : TIFF/GeoTIFF (*.tiff); JPEG2000 (*.jp2); JPEG (*.jpg); PNG (*.png); BMP (*.bmp); Google Earth KMZ (*.zip); MBTiles (*.mbtiles); World Wind Tiles (*.zip); Tile Map Service Tiels (*.zip). 


  • Экспорт ЦММ

1. Выберите команду Экспорт ЦММ в меню Файл

2. В диалоговом окне Экспорт ЦММ укажите систему координат привязки матрицы высот. Поставьте галочку Создать файл KML и/или Создать файл World, чтобы создать файлы, необходимые для пространственной привязки ортофотоплана в Google Earth и/или ГИС-программах.

Примечание. В Metashape доступен экспорт ЦММ, окрашенных из палитры RGB. Выберите параметр "Палитра" в списке Преобразование растра диалогового окна Экспорт ЦММ. Выбор палитры поддерживается для следующих форматов экспорта: TIFF, JPEG, JPEG2000, PNG.


3. Нажмите кнопку Экспорт.

4. Выберите папку сохранения, формат файла и введите его название. Нажмите кнопку Сохранить.

5. Появится окно процесса выполнения, отображающее текущее состояние обработки. Чтобы отменить обработку, нажмите кнопку Отмена.


Metashape поддерживает экспорт ЦММ в следующие форматы: GeoTIFF elevation data (*.tif); Arc/Info ASCII Grid (*.bil); XYZ file format (*.xyz); Sputnik KMZ (*.kmz); Google Map Tiles (*.zip); MBTiles (*.mbtiles); World Wind Tiles (*.zip); Tile Map Service Tiles (*.zip).