Agisoft Metashape Professional 1.6 позволяет обрабатывать панхроматические и мультиспектральные спутниковые снимки, при условии, что для каждого из них доступны достаточно точные данные Rational Polynomial Coefficients (RPC)Коэффициенты RPC загружаются автоматически, если они присутствуют в теге коэффициента RPC мета-данных EXIF спутникового снимка. Кроме того, они могут быть загружены из дополнительных файлов rpc.txt или .rpb, если такие есть.

Снимки, использованные в данной инструкции, доступны на веб-сайте ISPRS:

https://www.isprs.org/data/ikonos_hobart/default.aspx


Загрузка спутниковых снимков  (с коэффициентами RPC)

1. Если коэффициенты RPC представлены в виде дополнительных файлов rpc.txt или .rpb, то перед добавлением снимков в проект откройте вкладку Дополнительно в меню Инструменты > Настройки и включите опцию Загружать RPC данные для спутниковых снимков из вспомогательных TXT файлов.

2. Для того чтобы удостовериться, что коэффициенты RPC были загружены правильно, откройте окно Калибровка камеры, доступное в меню Инструменты и проверьте что Тип камеры для группы спутниковых изображений автоматически определен как Спутниковая.

Примечание: 

  • Спутниковые изображения часто имеют очень большое разрешение, и навигация в окне просмотра Снимки  может быть замедленной. Metashape может использовать TIFF-файлы с несколькими разрешениями и обзорные TIFF, которые значительно ускоряют просмотр.
  • Если доступные спутниковые снимки не содержат обзорных изображений, рекомендуется их создать с помощью функции Преобразовать снимки.


Создание оптимизированных изображений TIFF для ускорения навигации

1. Добавьте оригинальные снимки в пустой блок.

2. Выберите команду Файл > Экспорт > Преобразовать снимки...

3. В диалоговом окне Преобразовать снимки подключите опции Сохранять тайловый TIFF... и Сохранять обзорные изображения TIFF... Если размер снимка превышает 4 ГБ, дополнительно подключите опцию Сохранять BigTIFF файл.

4. Проверьте, что шаблон имени файла имеет приемлемый вид. Шаблон {filename}.{fileext} (установленный по умолчанию) должен работать в большинстве случаев.

5. В разделе Применить к выберите Все камеры и нажмите кнопку ОК.

6. В открывшемся диалоговом окне выберите папку для сохранения оптимизированных изображений. Рекомендуется выбрать новую пустую папку, чтобы исключить возможность записи новых файлов поверх исходных. Нажмите кнопку Выбрать папку, чтобы начать преобразование.

7. Полученные в результате преобразования снимки могут быть загружены в новый блок для обработки.

 

Примечание. Команда Преобразовать снимки автоматически встраивает коэффициенты RPC в мета-данные EXIF оптимизированных снимков, поэтому не нужно копировать вспомогательные TXT-файлы в новую папку со снимками.


Выравнивание снимков

1. Создайте новый блок на панели Проект и добавьте снимки с помощью команды Добавить снимки в меню ОбработкаЕсли доступны вспомогательные текстовые файлы с коэффициентами RPC, убедитесь, что имена снимков соответствуют именам вспомогательных файлов.

2. В диалоговом окне Калибровка камеры проверьте, что Тип камеры для группы спутниковых снимков - Спутниковая.

3. Выберите команду Выровнять снимки в меню Обработка и выставьте необходимые настройки. Если количество обнаруженных связующих точек не соответствует требуемому значению, может быть включена опция Локальный поиск соответствий. Нажмите кнопку ОК.


Оптимизация

1. Нажмите кнопку Оптимизировать камеры на панели Привязка.

2. В диалоговом окне отметьте параметр Уточнять cx, cy и нажмите кнопку ОК.

Построение плотного облака точек

1. Выберите команду Построить плотное облако... в меню ОбработкаУстановите следующие рекомендуемые значения для параметров. Нажмите кнопку ОК.


Построение цифровой модели местности (ЦММ)

1. Выберите команду Построить ЦММ... в меню ОбработкаУстановите следующие рекомендуемые значения для параметров в диалоговом окне (общий размер и разрешение рассчитываются автоматически). Нажмите кнопку ОК.

Построение ортофотоплана

1. Выберите команду Построить ортофотоплан...  в меню Обработка

2. В диалоговом окне Построить ортофотоплан задайте следующие рекомендуемые параметры. Нажмите кнопку ОК.