Данное руководство охватывает основные этапы обработки, относящиеся к обработке данных с мультисенсорной камеры:

  •  добавление изображений с использованием многокамерной системы (мультисенсорной камеры);
  •  калибровка отражательной способности;
  •  выравнивание снимков и оптимизация;
  •  создание моделей поверхности (плотное облако, ЦММ);
  •  построение ортофотоплана;
  •  расчет индексов с помощью инструмента Преобразование растра;
  •  экспорт данных.


Последовательность действий


1) Добавление снимков.


Изображения с камер MicaSense RedEdge-MX, MicaSense RedEdge, MicaSense Altum и Parrot Sequoia могут быть загружены одновременно для всех диапазонов. 


  • Если все изображения находятся в одной папке

Откройте меню Обработка и выберитеДобавить снимки. Выберите все изображения, включая калибровочные изображения, и нажмите ОК. В диалоговом окне Добавить снимки в качестве структуры данных выберите опцию Многокамерная система: 

  • Если изображения рассортированы в отдельные папки для каждого сенсора:

Откройте меню Обработка и выберитеДобавить папку. Выберите общую папку, содержащую папки со снимками с каждого сенсора, и нажмите ОК. В диалоговом окне Добавить снимки в качестве структуры данных выберите опцию Многокамерная система.


Важно: не забудьте добавить изображения с калибровочной пластиной! Metashape Pro может автоматически отсортировать калибровочные изображения в специальную папку Calibration images на панели Проект, если мета-данные изображения сообщают, что оно предназначено для калибровки. Такие изображения будут автоматически заблокированы (не будут использоваться при фактической обработке). 

Если же в мета-данных изображений нет нужной информации, калибровочные изображения все равно могут быть обнаружены автоматически (на следующем этапе), или отдельная папка для калибровочных изображений может быть создана вручную в папке Камеры на панели Проект, после чего можно перенести в нее изображения.


2) Поиск отражательных панелей для калибровки.


Откройте меню Инструменты и выберите пункт Калибровать отражательную способностьНажмите кнопку Найти панели:

Найденные изображения с панелью будут перемещены в отдельную папку, лишние части изображения (помимо самой панели) будут автоматически закрыты маской. Если изображения не переместились автоматически, используйте способ, описанный в Приложении A. Если панель используется впервые, и ее калибровка еще не добавлена во внутреннюю базу данных Metashape Pro, программа предложит загрузить калибровку из CSV файла: 

Если файл CSV с информацией о калибровке отражательной способности отсутствует, значения калибровки могут быть заданы вручную на следующем шаге. Файл CSV для радиометрической панели MicaSense может быть запрошен у MicaSense напрямую:  https://www.micasense.com/prv 


3) Ввод значения коэффициента отражения (альбедо) калибровочной панели


Данный шаг может быть пропущен, если на предыдущем этапе калибровка отражательной способности была загружена из файла CSV или из базы данных калибровки. 

После того, как были найдены калибровочные панели, следует ввести значения отражательной способности, соответствующие каждому каналу, согласно сертификату панели. Это можно сделать вручную в диалоговом окне Калибровать отражательную способность или с помощью кнопки Выбрать панель..., как описано в 

Приложении Б данного руководства.

4) Запуск калибровки отражательной способности.


В диалоговом окне Калибровать отражательную способность выберите опции Использовать калибровочные панели и Использовать сенсор освещённости, чтобы выполнить калибровку на основе данных панели и/или мета-данных изображения. Нажмите OK, чтобы начать процесс калибровки.


5) Выравнивание снимков.


Откройте диалоговое окно Выровнять снимки в меню Обработка и используйте следующие параметры:

Результат выравнивания будет показан в виде облака связующих точек (состоит из общих точек между изображениями) и синих прямоугольников, отображающих рассчитанное положение и ориентацию снимков:

Ограничительная рамка определяет область построения для следующих этапов обработки, таких как Построение плотного облака, ЦММ, полигональной модели, тайловой модели, ортофотоплана. При необходимости ее можно настроить вручную с помощью инструментовПовернуть область,

Изменить размер области иПереместить область. 


6) Оптимизация


Для повышения точности выравнивания камер и координатной привязки используйте инструмент

Оптимизировать камеры. Предварительно нужно задать точность привязки (если эта информация есть) в настройках  Параметры привязки. Также, если на территории есть марки с известными координатами, то рекомендуется загрузить их координаты, расставить соответствующие маркеры, и задать точность координат в Параметрах привязки. Это позволит уточнить не только привязку итоговых моделей, но и элементы внутреннего ориентирования снимков, что положительно повлияет на качество реконструкции. 

Рекомендуется использовать следующие параметры оптимизации:


7) Построение плотного облака.


Для более точного восстановления поверхности рекомендуется построить плотное облако точек. Это также приведет к улучшению качества конечного ортофотоплана.

В меню Обработка откройте диалоговое окно Построить плотное облако и используйте следующие параметры:

Использование более высокого качества позволит построить более точную поверхность (большее количество точек), но обработка займет больше времени. В большинстве случаев (особенно при малой изменчивости характера поверхности) для обработки аэрофотоснимков достаточно среднего качества.

Если экспорт плотного облака не требуется, то рекомендуется отключить опцию Расчет цветов точек, так как это немного сократит время обработки, а также уменьшит размер проекта (сохраненный проект будет занимать меньше пространства на диске).


Итоговое плотное облако точек будет отображаться в окне просмотра Модель:


Если исходные каналы снимков имеют метки RGB, Metashape попытается отобразить цвета точек плотного облака соответственно. В противном случае основной канал будет отображаться в режиме оттенков серого. 

Для переключения основного канала используйте параметр Задать основной канал в меню Инструменты:

8) Построение ЦММ.


Цифровая модель местности (ЦММ) может быть использована в качестве исходных данных для создания ортофотоплана. При этом время, необходимое для создания ЦММ, меньше времени построения полигональной модели, а качество результирующего ортофотоплана сопоставимо. Исключение составляют ситуации, когда необходимо построить ортофотоплан местности с сильно расчлененным рельефом, в таких случаях рекомендуется использовать полигональную модель как основу для ортофотоплана.

Откройте окно Построить ЦММ в меню Обработка и используйте следующие параметры:

Обратите внимание, что в качестве исходных данных необходимо обязательно выбрать Плотное облако. Также необходимо выбрать систему координат для верной интерпретации данных привязки и метод интерполяции. 

Значение Экстраполированная параметра Интерполяция позволит получить непрерывную поверхность и распространить ее на всю область построения (внутри ограничивающей рамки). При выборе значения параметра Интерполяция: Включена (по умолчанию) ЦММ будет содержать только информацию для областей, которые видны хотя бы на одном выровненном снимке.


Для того чтобы открыть ЦММ для просмотра, на панели Проект найдите построенную ЦММ в активном блоке и дважды щелкните по ней. Итоговая ЦММ будет отображаться в окне просмотра Орто:

9) Построение ортофотоплана.


В меню Обработка откройте диалоговое окно Построить ортофотоплан и используйте следующие параметры:

В качестве исходной поверхности используйте ЦММ. При необходимости отрегулируйте разрешение итогового ортофотоплана, нажав кнопку Метры...

Обратите внимание на параметр Режим смешивания. В случае если требуется исключить любое наложение или усреднение информации на изображениях, рекомендуется использовать значение Отключено.


Ортофотоплан может быть открыт для просмотра в окне Орто, для этого в активном блоке на панели Проект следует дважды щелкнуть на экземпляр ортофотоплана:

0) Расчет необходимых индексов.


В меню Инструменты выберите функциюПреобразование растра. В открывшемся окне Растровый калькулятор на вкладке Преобразование введите формулу расчета индексов, значения которых требуется получить по исходным данным.

Можно ввести более одной формулы. Это полезно в случае, если необходимо экспортировать ортофотоплан с несколькими выходными каналами (связанными с различными индексами), или если рассчитанные индексы должны быть представлены в режиме псевдо цветов.


На вкладке Палитра выберите способ визуализации. Для этого в поле Канал: выберите один из рассчитанных индексов или используйте представление Псевдо цвета для визуализации сразу трех выходных каналов (обратите внимание, что в режиме Псевдо цвета значения используемых выходных каналов должны находиться в диапазоне от 0 до 1 для правильного представления цветов RGB, кроме того значения будут автоматически масштабироваться до 8-битного представления RGB).  


На следующем рисунке показано представление выходного канала (в данном случае B1), определенного на вкладке ПреобразованиеЦветовое представление индекса можно выбрать из списка палитр, загрузить из файла *.clr или задать вручную, если это необходимо.
В поле Диапазон под гистограммой представлены абсолютные значения для выбранного индекса (выходного канала). Цвета палитры будут распределены внутри диапазона следующим образом: Минимальное значение диапазона соответствует значению 0 в цветовой шкале палитры и Максимальное значение диапазона соответствует значению 1 цветовой палитры:

Для представления ортофотоплана в псевдо цветах (RGB): на вкладке Преобразование отключите опцию Включить преобразование, на вкладке Палитра выберите значение Псевдо цвета в поле Канал и установите соответствие между выходными каналами и цветами палитры RGB. Область гистограммы можно проигнорировать:


11) Экспорт результатов.


Для экспорта ортофотоплана используйте меню Файл Экспорт Экспорт ортофотоплана:


Обратите внимание на параметр Преобразование растра в диалоговом окне Экспорт ортофотоплана. Доступны следующие значения параметра:

  • Нет - означает, что экспортированный ортофотоплан будет содержать каналы, в соответствии с исходными данными, а любые формулы преобразования будут игнорироваться;
  • Значение индекса - эта опция позволяет сохранить выходные каналы, определенные формулами преобразования в окне Растровый калькулятор;
  • Цвет индекса - сохранит ортофотоплан в цветах RGB в соответствии с настройками палитры в диалоговом окне Растровый калькулятор. Экспортированное растровое изображение будет выглядеть идентично отображению ортофотоплана в режиме просмотра Орто при условии, что на вкладке Преобразование выбрана опция Включить преобразование.

Metashape Professional выполняет операцию калибровки отражательной способности в соответствии с рекомендациями MicaSenseТаким образом, значения в выходных каналах будут 16-разрядными целочисленными (что справедливо также для входных значений), однако 100%-ная отражательная способность для каждого канала будет соответствовать середине доступного диапазона, то есть значению 32768. Если необходимо экспортировать коэффициент отражения, нормализованный до диапазона 0 - 1, то в диалоговом окне Растровый калькулятор для выходных каналов необходимо задать формулы:

B1 / 32768; В2 / 32768; B3 / 32768; В4 / 32768; B5 / 32768:

Затем в диалоговом окне Экспорт ортофотоплана для параметра Преобразование растра выберите Значение индекса


Приложение А. Использование изображений отражающих панелей для калибровки в ручном режиме. Наложение масок.


Если по какой-либо причине калибровочные панели не могут быть обнаружены автоматически (например, если калибровочная пластина не поддерживается и не является радиометрической панелью MicaSense), а папка Calibration images не создается автоматически, то следует в активном блоке вручную создать группу камер и назвать ее Calibration images. Затем следует переместить калибровочные изображения в эту группу и заблокировать их. Для того чтобы создать новую папку на панели Проект, выберите изображения, которые содержат калибровочную пластину, щелкните правой кнопкой мыши по ним и выберите Переместить камерыНовая группа, затем щелкните правой кнопкой мыши по созданной папке и переименуйте ее в Calibration images. В случае определения калибровочных изображений вручную, необходимо также применить маски ко всем таким изображениям.  


Алгоритм наложения маски:

1. Открыть калибровочное изображение;

2. Меню Фото → Выделение контура. Обвести контур калибровочной пластины, немного отступая от краев. 

3. Правой кнопкой мыши щелкнуть внутрь контура, выбрать Инвертировать выделение, чтобы маска наложилась на весь кадр, кроме самой пластины (маска отображается в виде затемнения).

Необходимо применять маски для каждого калибровочного изображения и для каждого входного канала! Для переключения между каналами используйте опцию Задать основной канал в меню Инструменты или в контекстном меню, вызываемом нажатием правой кнопки мыши по активному блоку на панели Проект.


После завершения процедуры наложения масок перейдите к шагу 3 этой инструкции и введите значения коэффициента отражения для каждого канала, затем перейдите к процедуре калибровки.


Приложение В. База данных отражающих панелей.


Metashape хранит информацию об использованных отражающих панелях. Таким образом, при обнаружении калибровочных изображений с той же панелью Metashape автоматически предложит значения отражательной способности из внутренней базы данных. База данных отражающих панелей может быть отредактирована. Для этого в диалоговом окне Калибровать отражательную способность следует нажать кнопку Выбрать панель и в появившемся диалоговом окне Выбрать калибровочную панель внести необходимые изменения.


В диалоговом окне Выбрать калибровочную панель можно:

- загрузить информацию об отражательной способности из файла CSV;

- сохранить текущую таблицу (длина волны / коэффициент отражения);

- отредактировать имя панели в базе данных (имя используется в диалоге Калибровать отражательную способность);

- удалить информацию о панели из базы данных.


Приложение С. Контроль расчета коэффициента отражения.


Расчет отражательной способности можно включить/отключить отдельно для каждого сенсора в диалоговом окне Калибровка камеры

Если результаты калибровки отражательной способности должны быть приняты во внимание в процессе построения ортофотоплана, откройте диалоговое окно Калибровка камеры в меню Инструменты и убедитесь, что опция Нормировать чувствительность канала включена: